This page has not been translated yet and is shown in Spanish.

2025.0.0.309

Publicada el 02/01/2025.

Novedades

  • El programa pierde precisión al cargar archivos E57 sin el elemento pose de posición y orientación. (commit)
  • Se ha añadido soporte para cargar panorámicas de archivos E57 representadas mediante seis imágenes, una por cara de un cubo (cubemaps). (commit)
  • Se ha añadido un nuevo tipo de dispositivo de entrada para la ventana fotogramétrica que reciba coordenadas por UDP (User Datagram Protocol) sobre IP (Internet Protocol). (commit)
  • Al hacer doble clic en un registro del panel Editor de Base de Datos con una ventana fotogramétrica abierta, el programa no desplaza la ventana fotogramétrica a las coordenadas de la geometría seleccionada. (commit)
  • Se ha mejorado la precisión con la que se proyectan puntos en un .LAS. (commit)
  • Se ha añadido la orden PERP_Z que dibuja una perpendicular proyectando la Z del segmento seleccionado. (commit)
  • Se ha modificado el programa para que las tareas del panel de tareas que muestran el error de "Polígono sin área" se puedan grabar y cargar con las órdenes de GUARDAR_TAREAS y CARGAR_TAREAS. (commit)
  • Ahora se oculta por defecto la opción de "Sistema de referencia de coordenadas" de la pestaña "Archivo de dibujo" del cuadro de diálogo "Nuevo proyecto". (commit)
  • Ahora se oculta la pestaña "Ventana de dibujo" en el cuadro de diálogo "Selecciona el sistema de referencia de coordenadas a asignar al archivo" cuando se abre la ventana de dibujo con un dibujo nuevo, pues no hay ninguna ventana de dibujo creada. (commit)
  • Ahora se muestra la pestaña "Ventana fotogramétrica" en el cuadro de diálogo "Selecciona el sistema de referencia de coordenadas" si hay una ventana fotogramétrica abierta. (commit)
  • Ahora se captura el ratón al desplazar la rueda en la ventana fotogramétrica para permitir un movimiento sin límites. (commit)
  • Se han mejorado el rendimiento y la precisión al localizar el punto más cercano al rayo en el sensor Point Cloud. (commit)
  • Se ha añadido animaciones en la ventana fotogramétrica al hacer doble clic para ir a un punto con el sensor Point Cloud. (commit)
  • Se ha modificado el programa para que al pulsar con el botón derecho del ratón y moverlo con el botón derecho pulsado en la ventana fotogramétrica con un modelo cargado de tipo PointCloud se desplace la cámara. (commit)
  • Se ha añadido un desplegable en el campo "Tabla de códigos" de la pestaña "Archivo de dibujo" del cuadro de diálogo "Nuevo proyecto" que muestre un histórico de las tablas de códigos utilizadas. (commit)

Correcciones

  • En determinadas tablas de códigos, la columna NOMBRE de la pestaña Expresiones del Editor de Tablas de Códigos muestra como nombre la expresión Python. (commit)
  • El cargador de archivos .ASC no respeta los códigos de las geometrías. (commit)
  • El exportador de archivos .ASC no almacena códigos con más de 6 caracteres. (commit)
  • Error en la Z seleccionada en los nodos de los recintos topológicos para los casos particulares de un código con otros códigos (commit)
  • La Z del polígono topológico era incorrecta si se seleccionaba como criterio general de la topología Obtener la Z del polígono del centroide u obtener la Z del polígono de un MDT. (commit)
  • Al ejecutar la orden SALIR, si el archivo de dibujo es un DGN, es posible que el programa no almacene correctamente las últimas modificaciones. (commit)
  • La orden PERP no proyecta en el plano activo si está habilitada la opción experimental "Proyección de punto a recta mejorado". (commit)
  • El programa se cierra inesperadamente si está habilitada la opción de detectar nuevas versiones y el ordenador no tiene internet. (commit)
  • Al cargar archivos .XML de MetaShape con certificados de cámara original y ajustada, el programa carga el primer certificado que encuentra en vez del certificado de la cámara ajustada. (commit)
  • Al cargar archivos .PRJ de Inpho con múltiples calibraciones de una misma cámara, se carga siempre la última calibración, que no tiene por qué ser la activa. (commit)
  • No se pueden cargar archivos .E57 en directorios con caracteres especiales. (commit)
  • El cursor de la ventana de dibujo no se representa como un círculo al seleccionar la forma circular. (commit)
  • La orden PARALELA entra en un bucle infinito al ejecutarla desde la línea de comandos. (commit)