2017.0.0.0
Publicada el 29/08/2016.
Novedades
- Ahora puedes instalar simultáneamente las versiones de 32 y 64 bits del programa en la misma máquina.
- Se ha añadido una orden para crear centroides para los polígonos que no tienen centroide. Se ha reestructurado además el menú de Topología y se ha añadido esta nueva opción.
- Se han añadido opciones al exportar topologías para que se pueda indicar si la Z del polígono se extrae del centroide, en 2.5D o en 3D.
- Ahora el programa carga de forma nativa proyectos de Pix4D.
- Ahora el programa carga de forma nativa proyectos de PhotoScan. (commit)
- Se han realizado modificaciones en los archivos de cámaras para poder emular cualquier cámara con el formato clásico de Digi3D. (commit)
- Se ha añadido una opción para permitir seleccionar el orden de los ejes en los Sistemas de Referencia de Coordenadas proyectados. (commit)
- Se ha añadido la posibilidad de cargar de forma nativa proyectos satelitales de Inpho, en coordenadas geográficas o en coordenadas proyectadas. (commit)
- Ahora puedes cargar imágenes en formato JPEG en la ventana fotogramétrica. (commit)
- Se ha añadido la posibilidad de deshabilitar extensiones de cámaras al cargar el programa. De esta manera se puede hacer que el programa cargue más rápido y que consuma menos recursos. (commit)
- Se ha añadido un indicador para insertar automáticamente vértices en las intersecciones de la línea que acabas de digitalizar. Con el indicador activado, el programa inserta automáticamente vértices en las intersecciones de la línea al finalizar la digitalización. (commit)
- Ahora el tentativo inserta vértices en polígonos.
- Ahora el programa es capaz de analizar relaciones geométricas entre entidades: punto-punto, punto-línea, punto-área, etc. (commit)
- Se han añadido comprobaciones de compatibilidad entre el esquema de un archivo .DBF y la tabla de códigos activa.
- Se ha añadido análisis de modelo semántico en tiempo real. Al digitalizar una entidad, el programa analiza sus relaciones geométricas y muestra los errores detectados. (commit)
- Se ha añadido una orden para rotar las imágenes de la ventana fotogramétrica en tiempo real. Se ha añadido esta opción al menú de Ventana Fotogramétrica. (commit)
- Ahora puedes seleccionar el tema con el que la aplicación muestra menús, barras de herramientas, paneles y cuadros de diálogo. (commit)
- Ahora puedes añadir alias a los códigos, para poder seleccionar un código mediante un alias. (commit)
- Se ha mejorado la comunicación de errores al seleccionar el código de la entidad al cargar archivos de dibujo en formato Geomedia con atributos existentes en las condiciones.
- Se han añadido operadores de comparación en las condiciones de los campos. Ahora puedes indicar que se debe seleccionar un código en particular si algún atributo tiene un valor mayor, mayor o igual, menor o menor o igual que un valor especificado. (commit)
- Ahora puedes indicar si el panel de campos de la base de datos debe mostrar el nombre del campo, el título del campo o ambos.
- Se ha añadido soporte para carga de orientaciones por coeficientes polinómicos racionales (RPC) de archivos NITF (National Imagery Transmission Format).
- Ahora el sensor satelital muestra los parámetros de los RPCs al seleccionar la opción del menú Ventana fotogramétrica/Información.
- Se ha añadido el panel de Propiedades de la entidad seleccionada, que permite mostrar los atributos de base de datos de la entidad que acabas de seleccionar.
- Ahora la orden XYZLINEA permite seleccionar entidades de archivos de referencia.
- Se ha añadido la posibilidad de agrupar campos de base de datos. https://blog.digi21.net/2016/05/20/agrupando-grupos-de-atributos-de-bbdd-en-digi3d-net/
- Se ha añadido soporte para interpretación de la rotación indicada en los metadatos EXIF (Exchangeable Image File Format) en archivos JPEG.
- Se ha añadido soporte para órdenes a ejecutar al seleccionar cualquier código. Ahora puedes indicar la serie de órdenes que se ejecutarán cuando selecciones un código. (commit)
- Se ha añadido un panel de cambio rápido de imágenes al cargar proyectos fotogramétricos. Ahora puedes cargar en el panel proyectos fotogramétricos creados con programas que no tienen concepto de par estereoscópico. (commit)
- Ahora puedes asociar a un código un guion .NET que se ejecutará al almacenar una entidad con ese código. ([commit](Ahora se puede ejecutar un guion en cualquier lenguaje de programación .NET asociado a un código, de manera que cuando se almacena una entidad se puede añadir lógica de negocio.))
- Se han añadido métodos de cálculo de perímetros a la calculadora administrada. Se han añadido los métodos CalculatePerimeter2D y CalculatePerimeter3D al tipo Digi21.DigiNG.GeographicCalculator.
- El importador de Geomedia permite a los guiones .NET consultar los atributos de base de datos de una entidad importada.
- Se han añadido tipos administrados para comparar relaciones geométricas entre entidades: PointPoint, PointLine, PointArea, LineLine, LineArea, AreaArea.
- Se ha mejorado la comunicación de errores del sensor A3 (VMQuasiPanoramic). Ahora, si no se puede cargar el archivo .dat de orientaciones, el programa indica que una posible causa es la presencia de caracteres especiales, como letras con tilde, en la ruta del archivo. Las librerías proporcionadas por VisionMap no permiten cargar archivos en rutas con caracteres especiales.
- Se ha añadido cálculo de rectificación epipolar al sensor A3 (VM-QuasiPanoramic). (commit)
- Ahora puedes almacenar macroinstrucciones en las tablas de códigos Digi.tab.xml. (commit)
- Ahora el programa puede reconocer órdenes de voz previamente asignadas en la tabla de códigos. (commit)
- Ahora al cambiar de modelo mediante el panel de proyecto fotogramétrico, se invierten y rotan las imágenes del modelo cargado si es necesario. Se han añadido dos opciones al cuadro de diálogo de configuración para indicar si se deben intercambiar las imágenes y rotarlas al cambiar de modelo mediante el panel de Proyecto fotogramétrico. Estas opciones permiten intercambiar y rotar las imágenes para que la orientación del nuevo modelo coincida con la del modelo que estaba abierto. (commit)
- Se ha eliminado del cuadro de diálogo Configuración la sección de Transformación de imágenes al vuelo. Las configuraciones que aparecían en esta sección no eran necesarias pues ya no se utilizan desde que Digi3D.NET realiza las transformaciones por hardware.
- Se ha añadido un cuadro de diálogo para añadir referencias a ensamblados en la tabla de códigos.
- Se ha reducido el tiempo de carga de las tablas de códigos.
- Se han añadido excepciones para comunicar errores de atributos en los guiones de los desencadenadores. Se han añadido las excepciones Digi21.DigiNG.DigiTab.ExcludedEntityException, Digi21.DigiNG.DigiTab.DatabaseAttributeException al ensamblado Digi21.DigiNG.
- Ahora las versiones de 32 y 64 bits comparten la configuración de OpenGis. Ya no es necesario copiar manualmente el modelo de geoide EGM2008 en la carpeta específica para la versión de 64 bits.
Correcciones
- Se ha solucionado un problema al añadir etiquetas por tabla en el editor de tablas de códigos. Se estaba añadiendo la etiqueta al siguiente código, y no al código en el que se pretendía añadir la etiqueta.
- El programa finaliza al comprimir en equipos con el programa recién instalado. Se ha solucionado este problema.
- Las órdenes MOD y MOD_Z finalizan el programa inesperadamente al modificar un polígono con huecos.
- La orden Z no estaba modificando la coordenada Z en la ventana fotogramétrica si la coordenada Z estaba bloqueada.
- Se ha solucionado un problema en las entidades enumeradas por Digi21.DigiNG.DrawingFile. Estas entidades no tenían asignada la propiedad Owner, por lo que se desconocía el archivo de dibujo al que pertenecían y no se podía acceder a las propiedades de la base de datos asociada a cada entidad.
- Se ha solucionado un problema en el programa Generador de Imágenes Piramidales. El programa podía finalizar inesperadamente al intentar procesar una cadena de caracteres enviada por la librería LibTIFF.
- La orden VELOCIDAD no muestra el cuadro de diálogo si hay abierta una ventana de dibujo. Se ha solucionado este problema, así como un problema relacionado en las órdenes ABRIR__BING_MAPS, CAMBIA_BRILLO_INDICE, MATRIZ_NIVELACION, MOSTRAR_FACTOR_CORRELACION, VELOCIDAD y ZOOM.
- Se ha solucionado un problema al calcular ortofotos si el SRC de la ventana de dibujo no coincide con el SRC del sensor. Ahora la orden CAL_ORTO realiza la transformación de coordenadas entre el sistema de referencia de coordenadas de la ventana de dibujo (que es el SRC en el que se calcula la ortofoto) y el sistema de referencia de coordenadas de la ventana fotogramétrica.
- Se ha solucionado un problema en el motor de EGM2008 que podía hacer que el programa finalizase inesperadamente si varios hilos de ejecución solicitaban simultáneamente datos a la rejilla EGM2008.
- La ventana fotogramétrica vuelve a mostrar los puntos medidos; la visualización se había deshabilitado al introducir las rotaciones de imágenes por hardware.
- El programa finaliza inesperadamente al crear niveles piramidales con archivos TIFF comprimidos en JPEG.
- Si cancelas la carga de un archivo de dibujo porque no se ha localizado la tabla de códigos especificada en la pestaña Archivo de dibujo, el programa finaliza inesperadamente.
- Se ha solucionado un problema en el cuadro de diálogo de configuración de proyectos de archivos. El programa no mostraba correctamente el sistema de referencia de coordenadas para la ventana de dibujo en la configuración. La vista de dibujo cargaba el sistema de referencia de coordenadas correcto.
- La orden LISTA no muestra correctamente el perímetro 3D de la entidad seleccionada. Se ha solucionado un problema que afectaba a las órdenes que requerían calcular módulos 3D en sistemas de referencia de coordenadas proyectados. El perímetro se calculaba en 2D y no en 3D.